Packet Tracer – Configuring RIPv2

Topology

  • Objectives

Part 1: Configure RIPv2

Part 2: Verify Configurations

  • Background

Although RIP is rarely used in modern networks, it is useful as a foundation for understanding basic network routing. In this activity, you will configure a default route, RIP version 2, with appropriate network statements and passive interfaces, and verify full connectivity.

  • Configure RIPv2
    • Configure RIPv2 on R1.
      • Use the appropriate command to create a default route on R1 for all Internet traffic to exit the network through S0/0/1.

R1(config)# ip route 0.0.0.0 0.0.0.0 s0/0/1

  • Enter RIP protocol configuration mode.

R1(config)# router rip

  • Use version 2 of the RIP protocol and disable the summarization of networks.

R1(config-router)# version 2

R1(config-router)# no auto-summary

  • Configure RIP for the networks that connect to R1.

R1(config-router)# network 192.168.1.0

R1(config-router)# network 192.168.2.0

  • Configure the LAN port that contains no routers so that it does not send out any routing information.

R1(config-router)# passive-interface gig 0/0

  • Advertise the default route configured in step 1a with other RIP routers.

R1(config-router)# default-information originate

  • Save the configuration.
    • Configure RIPv2 on R2.
      • Enter RIP protocol configuration mode.

R2(config)# router rip

  • Use version 2 of the RIP protocol and disable the summarization of networks.

R2(config-router)# version 2

R2(config-router)# no auto-summary

  • Configure RIP for the networks directly connected to R2.

R2(config-router)# network 192.168.2.0

R2(config-router)# network 192.168.3.0

R2(config-router)# network 192.168.4.0

  • Configure the interface that contains no routers so that it does not send out routing information.

R2(config-router)# passive-interface gig 0/0

  • Save the configuration.
    • Configure RIPv2 on R3

Repeat Step 2 on R3.

R3(config)# router rip

R3(config-router)# version 2

R3(config-router)# no auto-summary

R3(config-router)# network 192.168.4.0

R3(config-router)# network 192.168.5.0

R3(config-router)# passive-interface gig 0/0

  • Verify Configurations
    • View routing tables of R1, R2, and R3.
      • Use the appropriate command to show the routing table of R1. RIP (R) now appears with connected (C) and local (L) routes in the routing table. All networks have an entry. You also see a default route listed.
      • View the routing tables for R2 and R3. Notice that each router has a full listing of all the 192.168.x.0 networks and a default route.
    • Verify full connectivity to all destinations.

Every device should now be able to ping every other device inside the network. In addition, all devices should be able to ping the Web Server.

https://youtu.be/3bmmJ_2dMVs