Packet Tracer – Configuring Floating Static Routes

Topology

  • Objectives

Part 1: Configure an IPv4 Floating Static Route

Part 2: Test Failover to the IPv4 Floating Static Route

Part 3: Configure and Test Failover for an IPv6 Floating Static Route

  • Background

In this activity, you will configure IPv4 and IPv6 floating static routes. These routes are manually configured with an administrative distance greater than that of the primary route and, therefore, would not be in the routing table until the primary route fails. You will test failover to the backup routes, and then restore connectivity to the primary route.

  • Configure an IPv4 Floating Static Route
    • Configure an IPv4 static default route.
      • Configure a directly connected static default route from Edge_Router to the Internet. The primary default route should be through ISP1.

Edge_Router(config)# ip route 0.0.0.0 0.0.0.0 s0/0/0

  • Display the contents of the routing table. Verify that the default route is visible in the routing table.

Edge_Router# show ip route

<output omitted>

S*   0.0.0.0/0 is directly connected, Serial0/0/0

  • What command is used to trace a path from a PC to a destination? tracert

From PC-A, trace the route to the Web Server. The route should start at the default gateway 192.168.10.1 and go through the 10.10.10.1 address. If not, check your static default route configuration.

PC> tracert 198.0.0.10

Tracing route to 198.0.0.10 over a maximum of 30 hops:

  1   3 ms      0 ms      0 ms      192.168.10.1

  2   0 ms      1 ms      0 ms      10.10.10.1

  3   1 ms      2 ms      0 ms      198.0.0.10

Trace complete.

  • Configure an IPv4 floating static route.
    • What is the administrative distance of a static route? 0 for directly attached and 1 for recursive
    • Configure a directly connected floating static default route with an administrative distance of 5. The route should point to ISP2.

Edge_Router(config)# ip route 0.0.0.0 0.0.0.0 s0/0/1 5

  • View the running configuration and verify that the IPv4 floating static default route is there, as well as the IPv4 static default route.

Edge_Router# show run

Building configuration…

Current configuration : 781 bytes

!

<output omitted>

ip route 0.0.0.0 0.0.0.0 Serial0/0/0

ip route 0.0.0.0 0.0.0.0 Serial0/0/1 5

  • Display the contents of the routing table. Is the IPv4 floating static route visible in the routing table? Explain. No. It is not being displayed because it is not the primary route. Routers will only place the best path in the routing table and because this is the backup route, it will only be visible in the routing table when the primary route goes down.
  • Test Failover to the IPv4 Floating Static Route
    • On Edge_Router, administratively disable the exit interface of the primary route.

Edge_Router(config)# interface s0/0/0

Edge_Router(config-if)# shutdown

  • Verify that the IPv4 floating static route is now in the routing table.

Edge_Router# show ip route

<output omitted>

S*   0.0.0.0/0 is directly connected, Serial0/0/1

  • Trace the route from PC-A to the Web Server.

PC> tracert 198.0.0.10

Tracing route to 198.0.0.10 over a maximum of 30 hops:

  1   0 ms      0 ms      0 ms      192.168.10.1

  2   0 ms      0 ms      2 ms      10.10.10.5

  3   0 ms      2 ms      0 ms      198.0.0.10

Trace complete.

Did the backup route work? If not, wait a few more seconds for convergence and then re-test. If the backup route is still not working, investigate your floating static route configuration.

  • Restore connectivity to the primary route.

Edge_Router(config)# interface s0/0/0

Edge_Router(config-if)# no shutdown

  • Trace the route from PC-A to the Web Server to verify that the primary route is restored.

PC> tracert 198.0.0.10

Tracing route to 198.0.0.10 over a maximum of 30 hops:

  1   3 ms      0 ms      0 ms      192.168.10.1

  2   0 ms      1 ms      0 ms      10.10.10.1

  3   1 ms      2 ms      0 ms      198.0.0.10

Trace complete.

  • Configure and Test Failover to an IPv6 Floating Static Route
    • Configure an IPv6 floating static route.
      • The IPv6 static default route to ISP1 is already configured. Configure an IPv6 floating static default route with an administrative distance of 5. The route should point to IPv6 address (2001:DB8:A:2::1) of ISP2.

Edge_Router(config)# ipv6 route ::/0 2001:DB8:A:2::1 5

  • View the running configuration to verify that the IPv6 floating static default route is now listed under the IPv6 static default route.

Edge_Router# show run

Building configuration…

Current configuration : 781 bytes

!

<output omitted>

ipv6 route ::/0 2001:DB8:A:1::1

ipv6 route ::/0 2001:DB8:A:2::1 5

  • Test Failover to the IPv6 Floating Static Route.
    • On Edge_Router, administratively disable the exit interface of the primary route.

Edge_Router(config)# interface s0/0/0

Edge_Router(config-if)# shutdown

  • Verify that the IPv6 floating static route is now in the routing table.

Edge_Router# show ipv6 route

<output omitted>

S   ::/0 [5/0]

     via 2001:DB8:A:2::1

  • Trace the route from PC-A to the Web Server.

PC> tracert 2001:db8:f:f::10

Tracing route to 2001:db8:f:f::10 over a maximum of 30 hops:

  1   1 ms      0 ms      0 ms      2001:DB8:1:10::1

  2   0 ms      0 ms      1 ms      2001:DB8:A:2::1

  3   13 ms     0 ms      1 ms      2001:DB8:F:F::10

Trace complete.

Did the backup route work? If not, wait a few more seconds for convergence and then re-test. If the backup route is still not working, investigate your floating static route configuration.

  • Restore connectivity to the primary route.

Edge_Router(config)# interface s0/0/0

Edge_Router(config-if)# no shutdown

  • Trace the route from PC-A to the Web Server to verify that the primary route is restored.

PC> tracert 2001:db8:f:f::10

Tracing route to 2001:db8:f:f::10 over a maximum of 30 hops:

  1   0 ms      0 ms      0 ms      2001:DB8:1:10::1

  2   1 ms      0 ms      1 ms      2001:DB8:A:2::1

  3   1 ms      0 ms      1 ms      2001:DB8:F:F::10

Trace complete.

  • Suggested Scoring Rubric
Activity Section Question Location Possible Points Earned Points
Part 1: Configuring a Floating Static Route Step 1c 2  
Step 2a 3  
Step 2d 5  
Part 1 Total 10  
Packet Tracer Score 90  
Total Score 100